Введение

Программа RegWorks предназначена для работы с реестром операционных систем Windows 98/ME/NT/2k/XP.

RegWorks - редактирование и анализ реестра

Программа RegWorks может быть использована в качестве замены стандартного regedit. При этом доступны следующие дополнительные функции:

  • Многооконный интерфейс

    Окно программы может содержать несколько вкладок: редактор реестра, монитор и папка "Избранное". По умолчанию, показывается только окно редактора. Окно редактора реестра разбито на две части: дерево ключей, которое может быть минимизировано, и список окон, который изначально состоит только из окна редактора параметров ключа. При поиске в реестре и сравнении ключей в список добавляется новое окно. При помощи "горячих" клавиш можно быстро переключаться как между вкладками, так и между окнами редактора реестра.

  • Сравнение разделов

    Для любых двух разделов реестра программа может найти различия в наборе подключей, наборе и значениях параметров. Например, сравнив некоторый раздел и его сохраненную копию, можно выяснить какие подключи или параметры были удалены, какие добавлены, найти параметры, значения которых были изменены.

  • Поиск

    Операция поиска запускается в отдельном окне и не блокирует работу программы.

  • Загрузка и выгрузка разделов

    Загрузка и выгрузка разделов позволяет подключать файлы разделов к реестру и отключать уже подключенные разделы. Например, можно сравнить раздел с его предварительно сохраненной копией. Для этого нужно всего лишь подключить сохраненный раздел и воспользоваться функцией сравнения. Нужно отметить, что данная функция не вносит необратимых изменений в реестр. Загруженный раздел может быть в любой момент выгружен обратно.

  • Редактирование разрешений на разделы

    В операционных системах семейства NT (начиная с Win2k) RegWorks позволяет редактировать разрешения на разделы.

  • Работа с избранным

    Избранное может содержать не только разделы, но и параметры. Как для разделов, так и для параметров может быть задан комментарий.

  • Предпросмотр reg-файлов при импорте

    При импорте reg-файлов открывается окно предпросмотра с возможностью редактирования.

  • Экспорт отдельных параметров

    Можно экспортировать как весь раздел целиком, так и только некоторые его параметры.

  • Буфер обмена

    Раздел или параметры могут быть сначала скопированы или вырезаны в буфер обмена, а затем вставлены в другой раздел.

  • Строка быстрого перехода к разделу реестра

  • Работа программы в режиме только для чтения

RegWorks - монитор реестра

В случае систем, основанных на NT, RegWorks может также служить альтернативой программе RegMon. Встроенный монитор реестра позволяет:

  • Гибко настраивать правила фильтрации

    С помощью фильтров вы можете отслеживать только операции чтения, или только операции записи, следить за всеми процессами, или за каким-то одним. При желании, можно отслеживать доступ только к некоторому разделу или параметру.

  • Задавать правила подсветки строк и столбцов в журнале

    На основании некоторого признака или группы признаков можно задавать цвет фона столбца или строки в журнале монитора.

  • Экспортировать результаты наблюдения в текстовые и xml-файлы

    Результаты наблюдения могут быть сохранены не только в текстовом, но и в xml-формате. При помощи xslt-преобразования, xml-файл журнала монитора может быть преобразован к любому другому виду.

  • Просматривать содержимое журнала монитора в браузере.

    Html-страница для просмотра генерируется при помощи xslt-преобразования, которое задается в настройках программы.

Системные требования:

Windows 98/ME/NT4/2K/XP. Монитор реестра доступен только под NT4/2K/XP. Функция редактирования прав - 2K/XP.


Работа с реестром

Раздел содержит следующие главы:

  • Создание разделов и параметров
  • Удаление разделов и параметров
  • Переименование разделов и параметров
  • Изменение значений параметров
  • Поиск в реестре
  • Импорт и экспорт разделов
  • Загрузка и выгрузка разделов
  • Редактирование разрешений
  • Работа с удаленным реестром
  • Избранное
  • "Горячие" клавиши
  • Сравнение разделов


Создание разделов и параметров

Для того чтобы создать новый раздел, выделите в дереве разделов родительский раздел, затем в подменю Создать меню Правка выберите пункт Раздел. Введите имя нового раздела.

Для того чтобы создать новый параметр в некотором разделе, выделите этот раздел, затем в подменю Создать меню Правка выберите один из пунктов Строковый параметр, Параметр DWORD, Двоичный параметр или Мультистроковый параметр. Введите имя нового параметра.

Функции создания разделов и параметров доступны также из контекстного меню.


Удаление разделов и параметров

Чтобы удалить раздел или параметр, нужно выделить необходимый раздел или параметр и выбрать пункт Удалить меню Правка или одноименный пункт контекстного меню.


Переименование разделов и параметров

Чтобы переименовать раздел или параметр нужно выделить необходимый раздел или параметр и выбрать пункт Переименовать меню Правка или одноименный пункт контекстного меню.


Изменение значений параметров

Чтобы изменить значение параметра нужно выделить его в списке параметров и выбрать пункт Изменить значение меню Правка, или одноименный пункт контекстного меню.


Поиск в реестре

Чтобы начать поиск в каком-либо разделе, нужно выделить этот раздел и выбрать пункт Поиск... меню Сервис или одноименный пункт контекстного меню. В появившемся диалоговом окне следует ввести поисковое выражение и, если нужно, задать параметры поиска. Можно указать, что выражение следует искать в именах разделов, именах и значениях параметров, учитывая или не учитывая при этом регистр символов. Можно также потребовать полного совпадения, указав флаг Строка целиком. После запуска поиска будет открыто новое окно, в которое будут заноситься результаты. Операцию поиска можно прервать, выбрав пункт Прервать операцию меню Сервис

Чтобы из окна результатов перейти к найденному разделу или параметру нужно два раза щелкнуть на соответствующей записи.


Импорт и экспорт разделов

Любой раздел может быть сохранен в файл в одном из трех форматов: Regedit 4 (ansi .reg-файлы), Regedit 5 (unicode .reg-файлы) и в формате файлов кустов реестра. Раздел, сохраненный в одном из двух первых форматов может быть импортирован в реестр. Если раздел был сохранен в формате файла куста, то он может быть загружен в реестр (см. Загрузка и выгрузка разделов).

Чтобы экспортировать раздел (сохранить в файл) выделите этот раздел в дереве разделов, выберите пункт Экспортировать... меню Реестр, выберите нужный формат и имя файла. Если нужно экспортировать только некоторые параметры одного раздела, выделите эти параметры, выберите пункт Экспортировать... меню Реестр, выберите нужный формат и имя файла.

Чтобы импортировать (внести в реестр) экспортированный ранее раздел следует выбрать пункт Импортировать... меню Реестр и задать имя файла. После выбора файла откроется окно, в котором можно просмотреть и отредактировать содержимое файла (сам файл изменяться не будет). Появление этого окна в дальнейшем можно запретить, если в нем снять флаг Всегда показывать это окно или отредактировать настройки программы (пункт Настройка меню Сервис).

См. также: Загрузка и выгрузка разделов, Диалог предпросмотра импорта, Настройки программы


Загрузка и выгрузка разделов

Чтобы загрузить в реестр раздел из файла куста, нужно выбрать пункт Загрузить раздел... меню Реестр. После выбора файла куста, необходимо задать имя для загружаемого раздела и выбрать корневой раздел. Загрузить раздел можно только как подраздел HKEY_LOCAL_MACHINE, либо как подраздел HKEY_USERS. О создании файлов кустов читайте в главе Импорт и экспорт разделов.

Чтобы выгрузить загруженный раздел, нужно выделить его в дереве разделов и выбрать пункт Выгрузить раздел меню Реестр.


Редактирование разрешений

Под управлением систем на базе NT (Windows 2000 и более поздние версии), программа позволяет редактировать разрешения на разделы. Чтобы отредактировать разрешения на доступ к какому-либо разделу, выделите этот раздел в дереве разделов и выберите пункт Разрешения... меню Правка.


Работа с удаленным реестром

Чтобы подключиться к удаленному реестру, выберите пункт Подключить сетевой реестр меню Реестр. В диалоговом окне выберите компьютер, к реестру которого вы хотите подключиться. Если подключение прошло успешно, в дереве разделов будет создан новый узел с подузлами HKEY_LOCAL_MACHINE и HKEY_USERS удаленного компьютера. Чтобы отключиться от удаленного реестра, необходимо выделить иконку компьютера в дереве разделов и выбрать пункт Отключить сетевой реестр меню Реестр.


Избранное

Любой раздел или параметр может быть добавлен в папку "Избранное". Для этого выделите раздел или параметр и выберите пункт Добавить в избранное меню Правка. В появившемся диалоговом окне введите комментарий к разделу или параметру.

Избранное можно открыть, выбрав пункт "Избранное" меню "Вид". Если пункт меню выбрать повторно, то окно с избранным будет закрыто. Если при выходе из программы оставить окно с избранным открытым, то при следующем старте программы, оно будет открыто автоматически.


"Горячие" клавиши

Список "горячих" клавиш:

  • Ctrl+Del - удалить выделенные параметры или раздел реестра;
  • F2 - переименовать выделенный параметр или раздел реестра;
  • Ctrl+C или Ctrl+Ins - копировать выделенные параметры или раздел реестра;
  • Ctrl+V или Shift+Ins - вставить скопированные параметры или раздел реестра;
  • Ctrl+X - вырезать выделенные параметры или раздел реестра;
  • Ctrl+Alt+Right - активировать следующее окно (для вкладок "Реестр", "Избранное", "Монитор");
  • Ctrl+Alt+Right - активировать предыдущее окно (для вкладок "Реестр", "Избранное", "Монитор");
  • Ctrl+F4 - закрыть активное окно (для вкладок "Реестр", "Избранное", "Монитор");
  • Ctrl+Alt+Up - активировать предыдущее окно (для окон поиска, сравнения, редактора параметров);
  • Ctrl+Alt+Down - активировать следующее окно (для окон поиска, сравнения, редактора параметров);
  • Ctrl+W - закрыть активное окно (для окон поиска, сравнения, редактора параметров);
  • Ctrl+Z - очистить окно монитора реестра;
  • F5 - обновить дерево реестра и список параметров;
  • Ctrl+O - загрузить раздел;
  • Ctrl+F - поиск в реестре;
  • F3 - поиск текста в окне монитора реестра;
  • Ctrl+L - активировать список параметров раздела;
  • Ctrl+R - свернуть/развернуть дерево разделов;
  • Ctrl+G - группировать элементы дерева в окне результатов сравнения разделов;
  • Ctrl+Tab - переключение между окнами (для вкладок "Реестр", "Избранное", "Монитор");


Сравнение разделов

В следующих главах представлена информация о функции сравнения разделов и способах ее применения:

  • Сравнение двух разделов
  • Сравнение настроек разных пользователей
  • Отслеживание изменений в реестре


Сравнение двух разделов

Чтобы сравнить два раздела нужно выделить один из них в дереве разделов и выбрать пункт Сравнить... меню Сервис. Затем, в диалоге, следует выбрать второй раздел. Если при сравнении нужно учитывать и параметры, то должен быть установлен флаг Сравнивать параметры. После нажатия кнопки Ok, в редакторе откроется новое окно и начнется процесс сравнения. Операцию можно прервать, выбрав пункт Прервать операцию меню Сервис. Окно с результатами содержит две вкладки: "Разделы" и "Параметры".

Вкладка "Разделы" содержит дерево, имеющее два корневых узла. Потомками первого корневого узла являются те разделы, которые содержатся в первом выбранном разделе, но отсутствуют во втором. Потомками второго корневого узла являются, наоборот, те разделы, которые содержатся во втором выбранном разделе, но отсутствуют в первом. При этом учитываются только те разделы, относительные пути родителей которых (пути, отсчитываются от сравниваемых разделов) совпадают.

Вкладка "Параметры" содержит дерево, имеющее три корневых узла. Потомками первого корневого узла являются параметры, которые есть в первом разделе, но отсутствуют во втором. Потомками же второго корневого узла являются, напротив, параметры, которые есть во втором разделе, но отсутствуют в первом. Потомки третьего узла - это параметры, имеющие одинаковые имена, но разные значения. При этом учитываются только те параметры, которые принадлежат разделам с одинаковыми относительными путями (пути, отсчитываются от сравниваемых разделов).

И разделы и параметры можно группировать по общему предку. Для этого выделите элемент дерева, потомки которого нужно группировать и выберите пункт меню Группировать потомков меню Вид или одноименный пункт контекстного меню. При этом, если какие-либо потомки выбранного узла имеют общий предок-раздел, то в дерево будет добавлен узел этого предка и все его потомки будут перенесены в созданный узел. Имя предка будет удалено из имени потомков. Если операцию нужно повторить рекурсивно и для потомков нового раздела, то вместо пункта Группировать потомков нужно выбрать пункт Группировать всех потомков.

Чтобы перейти к интересующему разделу или параметру, нужно два раза кликнуть на его узле в дереве.

См. также: Сравнение настроек разных пользователей, Отслеживание изменений в реестре


Сравнение настроек разных пользователей

Функцию сравнения разделов можно использовать для сравнения настроек разных пользователей. Для этого, сначала, следует с помощью функции Загрузки разделов загрузить в реестр настройки этих пользователей. В Windows 2000 и XP настройки пользователя хранятся в файлах вида "c:\Documents And Settings\<имя пользователя>\ntuser.dat" (этот файл содержит HKEY_CURRENT_USER пользователя), в Windows NT путь "c:\Documents And Settings" следует заменить на "c:\winnt\profiles". Чтобы выявить различия в настройках пользователей, достаточно просто сравнить загруженные узлы.

См. также: Отслеживание изменений в реестре


Отслеживание изменений в реестре

Чтобы отследить внесенные в какой-либо раздел изменения, нужно сначала сделать эталонную копию этого раздела с помощью функции Импорт раздела. Импортировать раздел нужно в формат файлов кустов. Затем, в любой момент после того как в реестр были внесены некоторые изменения, можно сравнить раздел с его оригиналом, предварительно загрузив сохраненную копию с помощью функции Загрузка разделов.

Примечание: если нужно отслеживать изменения во всем реесте, то достаточно сделать копии только двух его разделов: HKEY_USERS и HKEY_LOCAL_MACHINE. Остальные корневые разделы являются ссылками на подразделы этих двух.


Монитор реестра

Раздел содержит следующие главы:

  • Общие сведения
  • Управление монитором
  • Фильтры
  • Подсветка


Общие сведения

Монитор представляет собой средство перехвата вызовов функций по работе с реестром. Перехват осуществляется с помощью драйвера, который устанавливается при первом старте программы. С определенной частотой, программа запрашивает у драйвера пакет записей с информацией о вызовах. И частота запросов и размер пакета могут быть изменены в настройках программы (пункт Настройка меню Сервис). Каждая запись содержит информацию об одном вызове: процесс, в контексте которого был произведен вызов, раздел реестра, к которому обратился процесс, результат вызова, имя функции и дополнительные параметры, зависящие от функции.

Имя функции может принимать одно из следующих значений:

  • RegOpenKey - открытие раздела для доступа, дополнительные параметры будут содержать запрошенные права доступа
  • RegCreateKey - создание нового раздела или открытие существующего
  • RegCloseKey - закрытие раздела
  • RegDeleteKey - удаление раздела
  • RegQueryInfoKey - запрос информации о разделе
  • RegLoadKey - загрузка раздела в реестр, дополнительные параметры будут содержать имя файла, из которого загружается раздел
  • RegUnloadKey - выгрузка раздела из реестра
  • RegEnumKey - перечисление подразделов, дополнительные параметры будут содержать имя очередного подраздела
  • RegEnumValue - перечисление параметров раздела, дополнительные параметры будут содержать имя очередного параметра
  • RegQueryValue - чтение значения параметра, дополнительные параметры будут содержать имя параметра
  • RegSetValue - изменение значения параметра, дополнительные параметры будут содержать имя изменяемого параметра
  • RegDeleteValue - удаление параметра, дополнительные параметры будут содержать имя удаляемого параметра
  • RegFlushKey - принудительная запись на диск всех параметров раздела

    Результат вызова может принимать одно из следующих значений:

  • Success - успешный вызов
  • Invalid handle - функции передан неверный описатель
  • Access denied - доступ запрещен
  • Not found - раздел или параметр не найден
  • No more entries - индекс раздела или параметра, в функциях перечисления, превысил максимально допустимое значение
  • Buffer overflow - размер буфера меньше размера запрашиваемых данных
  • Can not delete - ошибка при удалении раздела или параметра
  • Unknown error ... - любая другая ошибка

    Примечание: в журнал заносятся только те записи, которые разрешены установленным фильтром.

    См. также Фильтры


Управление монитором и журналом вызовов

Запуск монитора

Чтобы запустить монитор выберите пункт Запустить монитор меню Монитор. Если монитор запускается в первый раз, программа предложит создать новый фильтр с помощью мастера создания фильтров. После создания фильтра, программа делает его текущим и запускает монитор. В случае отмены создания фильтра, записи фильтроваться не будут, то есть, в журнал будет заноситься информация о всех вызовах. Подробнее о фильтрах смотрите главу Фильтры. В настройках программы можно указать, чтобы монитор запускался автоматически, при старте программы.

Остановка монитора

Чтобы остановить монитор выберите пункт Остановить монитор меню Монитор.

Сохранение журнала

Содержимое журнала может быть сохранено в файл либо в текстовом либо в xml-формате. Для этого выберите пункт Сохранить меню Монитор. При сохранении в xml-формате, в файле указывается ссылка на xslt-преобразование, которое будет использовано, например, при просмотре в браузере. По умолчанию, используется xslt-преобразование simple.xsl, идущее в комплекте с программой. В настройках программы можно указать любое другое преобразование.

Просмотр журнала в браузере

Чтобы просмотреть содержимое журнала в браузере, нужно выбрать пункт Открыть журнал в браузере меню Монитор. Программа сохранит журнал во временном xml-файле и откроет этот файл в браузере.

Поиск в журнале

Чтобы начать поиск в журнале, выберите пункт Найти... меню Монитор. Поиск начнется с первой выделенной строки в журнале, если выделенных строк нет, то поиск начнется с начала журнала.

Управление журналом

Чтобы очистить журнал, выберите пункт Очистить меню Монитор. Если пункт Автопрокрутка списка меню Монитор отмечен, то при добавлении новых записей содержимое журнала будет прокручено.


Фильтры

Чтобы получать информацию не обо всех вызовах, а только о тех, которые удовлетворяют некоторым условиям, следует использовать фильтры.

Состав фильтра. Каждый фильтр имеет название, выбираемое пользователем, и упорядоченный набор правил фильтрации. Правило фильтрации может быть либо разрешающим, либо запрещающим. Правило состоит из маски процесса, маски раздела, маски параметра и набора флагов, каждый из которых соответствует некоторой Reg-функции. Правило также содержит два флага: Успешные вызовы и Ошибочные вызовы.

Применение фильтра. При поступлении информации о новом вызове, драйвер начинает по порядку просматривать правила в текущем фильтре. Если вызов удовлетворяет правилу, и правило является разрешающим, то информация заносится в журнал; если правило является запрещающим, то просмотр правил заканчивается, а информация о вызове удаляется. Если вызов не удовлетворяет ни одному правилу, то информация о нем также удаляется. Вызов удовлетворяет правилу если выполняются все нижеперечисленные условия:

  • имя процесса, осуществившего вызов, удовлетворяет маске имени процесса в правиле
  • имя раздела, к которому обратился процесс, удовлетворяет маске имени раздела в правиле
  • если была вызвана одна из функций RegSetValue, RegQueryValue, RegDeleteValue или RegEnumValue, то имя параметра, к которому обратился процесс, должно удовлетворять маске имени параметра в правиле. Внимание! Имя параметра по умолчанию - пустая строка, а не "(По умолчанию)"
  • в правиле установлен флаг, соответствующий вызванной функции
  • вызов закончился неудачей и в правиле установлен флаг Ошибочные вызовы, либо вызов прошел без ошибок и в правиле установлен флаг Успешные вызовы

Простейшие фильтры могут быть созданы с помощью мастера создания фильтров. Чтобы воспользоваться всеми преимуществами предложенного механизма фильтрации, следует создавать фильтры с помощью Редактора фильтров. Текущий фильтр может быть установлен с помощью диалога Выбор фильтра.

См. также: Мастер создания фильтров, Редактор фильтров, Выбор текущего фильтра


Подсветка

Правила подсветки позволяют указать, что для некоторых строк или столбцов необходимо использовать особый цвет фона и текста. Подсветка задается упорядоченным набором правил. Каждое правило состоит из строковой маски, идентификатора столбца в журнале, цвета фона, цвета текста и параметра, позволяющего указывать область применения правила (строка или столбец).
Если содержимое ячейки удовлетворяет текстовой маске в правиле, и идентификатор столбца ячейки совпадает с тем, который указан в правиле, то правило называется применимым к данной ячейке.
При прорисовке целой строки, программа по порядку просматривает правила, область применения которых - "Строка". Если правило применимо к какой-либо ячейке текущей строки, то для всей строки используется тот цвет текста и фона, который указан в правиле. Если подходящего правила не нашлось, то при прорисовке каждой ячейки по порядку просматриваются правила с областью применения "Столбец", если правило применимо к текущей ячейке, то при прорисовке ее содержимого, используются цвета из правила. Если подходящего правила для ячейки не нашлось, то используются цвета по умолчанию.

См. также: Диалог редактирования правил подсветки


Интерфейс программы

Раздел содержит следующие главы:

  • Диалоги программы
  • Настройки программы


Диалоги программы

Раздел содержит следующие главы:

  • Диалог предпросмотра импорта
  • Диалог выбора фильтра
  • Диалог редактирования набора фильтров
  • Диалог редактирования фильтра
  • Диалог редактирования фильтрующего правила
  • Диалог мастера создания фильтров
  • Диалог редактирования правил подсветки


Диалог предпросмотра импорта

Диалог предпросмотра отображает содержимое импортируемого файла. Навигация по разделам осуществляется также как в проводнике Windows. В диалоге есть возможность удалять разделы и параметры (кнопка [image] на панели инструментов диалога), изменять значения параметров (кнопка [image]), переименовывать разделы и параметры. При этом все изменения осуществляются только в памяти, то есть не затрагивают исходный файл.


Диалог выбора фильтра

Диалог выбора фильтра позволяет сменить текущий фильтр монитора реестра. Для этого нужно выбрать имя фильтра в выпадающем списке и нажать кнопку Ok.

См. также: Фильтры


Диалог редактирования набора фильтров

С помощью диалога редактирования фильтров можно добавлять, удалять и изменять имеющиеся фильтры. Диалог содержит список с именами готовых фильтров. Чтобы отредактировать фильтр выберите его имя в списке и нажмите кнопку Изменить, при этом откроется окно редактора фильтра. Для удаления выделенного в списке фильтра нажмите кнопку Удалить. Чтобы создать новый фильтр нажмите кнопку Добавить. Новый фильтр может быть также создан с помощью мастера создания фильтров.

См. также: Редактор фильтра, Фильтры


Диалог редактирования фильтра

Диалог редактирования фильтра позволяет изменить имя фильтра и набор фильтрующих правил. Чтобы отредактировать фильтрующее правило выберите его в списке и нажмите кнопку Изменить, при этом откроется окно редактора фильтрующего правила. Для удаления выделенного в списке правила нажмите кнопку Удалить. Чтобы добавить новое правило нажмите кнопку Добавить. С помощью кнопок Повысить приоритет и Понизить приоритет можно изменять порядок следования правил в списке (подробнее о фильтрующих правилах читайте в главе Фильтры).

См. также: Фильтры


Диалог редактирования фильтрующего правила

С помощью диалога редактирования фильтрующего правила можно задать следующие параметры правила: тип правила, маска процесса, маска раздела, маска параметра, флаги результатов и определить набор функций. В текстовых полях можно указывать несколько масок, разделенных символом ';', маска может содержать следующие специальные символы: '*', '?'. Подробнее о параметрах фильтрующих правил читайте в разделе Фильтры.


Диалог мастера создания фильтров

Мастер создания фильтров позволяет создавать простейшие, но, в то же время, наиболее часто используемые фильтры. Чтобы создать фильтр, нужно задать его имя в поле Имя фильтра и выбрать некоторое значение из выпадающего списка. Возможны следующие варианты:

  • Отслеживать активность некоторых или всех процессов - в журнал будет заноситься информация о вызовах из контекста только того процесса, имя которого удовлетворяет маске в поле Имя процесса. Таким образом, если в поле Имя процесса указать "*", то в журнал будет заноситься информация о всех вызовах.
  • Отслеживать операции чтения некоторых или всех процессов - в журнал будет заноситься информация о попытках чтения данных из реестра процессом, имя которого удовлетворяет маске в поле Имя процесса.
  • Отслеживать операции записи некоторых или всех процессов - в журнал будет заноситься информация о попытках модификации реестра процессом, имя которого удовлетворяет маске в поле Имя процесса.
  • Отслеживать доступ к разделу - в журнал будет заноситься информация о попытках доступа к разделу, полный путь к которому удовлетворяет маске в поле Раздел, из контекста процесса, имя которого удовлетворяет маске в поле Имя процесса.

С помощью мастера можно создавать фильтры, состоящие только из одного фильтрующего правила. Для более тонкой и точной настройки фильтрации вызовов следует создавать фильтры в Редакторе фильтров.

См. также: Фильтры, Редактор фильтров


Диалог редактирования правил подсветки

Диалог позволяет редактировать правила подсветки записей, заносимых в журнал монитора. Чтобы добавить новое правило нужно нажать кнопку Добавить, при этом в список будет добавлена новая запись с пустой маской, которую можно отредактировать при помощи встроенной в список строки ввода. Чтобы удалить правило, выделите его в списке и нажмите кнопку Удалить. Чтобы изменить тот или иной параметр правила, выделите строку с правилом в списке, щелкните мышкой по ячейке, которую нужно отредактировать и измените ее значение при помощи появившегося элемента управления. Подробнее о правилах подсветки читайте в разделе Монитор: Подсветка.


Настройки программы

Диалог настройки программы можно вызвать, выбрав пункт Настройка меню Сервис.

Вкладка "Редактор" содержит следующие флаги:

  • Открывать при запуске последний активный раздел - если флаг установлен, то при запуске программа открывает тот раздел, который был выделен в дереве разделов при завершении предыдущего сеанса работы с программой.
  • Показывать ошибки при поиске и сравнении - если флаг установлен, то при завершении операции поиска или сравнения на экран будет выведено окно, содержащее список всех разделов, к которым не удалось получить доступ на чтение.
  • Показывать окно предпросмотра при импорте - если флаг установлен, то при импорте файла будет показано окно предпросмотра содержимого файла. Если флаг сброшен, то программа будет требовать подтверждения импорта.
  • Открывать при запуске окно редактора параметров - если этот флаг установлен, то при запуске открывается окно, в котором будут отображаться параметры разделов. По умолчанию этот флаг установлен.
  • Открывать при запуске окно редактора реестра - если этот флан установлен, то при запуске, на главное окно программы, добавляется вкладка с окном редактора реестра. Флаг можно сбросить, если вы планируете использовать программу только как монитор реестра.
  • Открывать reg-файлы с помощью RegWorks - если этот флаг установлен, то при попытке открыть reg-файл из файлового менеджера будет показано окно предпросмотра с содержимым файла. Перед импортом, вы сможете внести свои изменения или вообще отменить операцию.
  • Работать в режиме только для чтения - если этот флаг установлен, то все функции программы, с помощью которых можно внести изменения в реестр будут запрещены.

Вкладка "Монитор" позволяет задать следующие параметры:

  • XSLT-преобразование, которое используется монитором при экспорте журнала и при просмотре его содержимого в окне браузера (подробнее смотрите Управление монитором и журналом вызовов)
  • Частота опроса драйвера монитора (подробнее смотрите Монитор: Общие сведения)
  • Число извлекаемых за один раз записей (подробнее смотрите Монитор: Общие сведения)
  • Автоматический запуск монитора (флаг Запускать монитор при старте программы)


Контактная информация

Информацию о новых версиях можно получить на сайте программы: www.regworks.narod.ru. С автором можно связаться по электронной почте.